Update on Reported DNS Issues Affecting .co Domains
Resolved
Apr 18, 2026 at 12:02pm UTC
We wanted to provide a final update regarding the intermittent access issues that affected esign.edocs.co.
Cloudflare has confirmed that the issue impacting some .co domains has been fully resolved.
Cloudflare incident timeline:
Investigating: Apr 17, 2026 – 21:50 UTC (5:50 PM ET)
Monitoring: Apr 17, 2026 – 21:55 UTC (5:55 PM ET)
Resolved: Apr 18, 2026 – 02:00 UTC (10:00 PM ET, Apr 17)
Summary:
The issue was caused by instability at the .co top-level domain (TLD) DNS layer
It was not related to our application, infrastructure, or DNS configuration
During the incident window, some users experienced intermittent DNS resolution failures
Current status:
DNS resolution has stabilized across providers
Access to esign.edocs.co is fully operational
We are no longer observing any impact
If you continue to experience any issues, please let us know and we will investigate further.
Thank you for your patience.
Best regards,
Affected services